Créer une intégration XML
Vue d'ensemble
BarTender 2019 introduit de nouveaux types de bases de données texte, y compris les bases de données XML. Comme Designer peut désormais lire ces types de bases de données nativement, vous pouvez aussi les utiliser comme fichiers déclencheurs sans avoir besoin d'une transformation XLST.
Ce tutoriel vous guidera à travers les étapes suivantes :
- Utiliser un fichier XML comme base de données
- Configurer une intégration de fichier XML
- Tester et déployer votre intégration
Des données d'exemple utilisées dans le tutoriel sont fournies. Une fois que vous serez à l'aise avec celles-ci, n'hésitez pas à suivre les mêmes étapes avec vos propres données et étiquettes pour créer une intégration XML adaptée à vos besoins.
Applicable à
BarTender 2019 et versions ultérieures
Informations
Créer une base de données XML
Voici un exemple de base de données XML pour une entreprise fictive de nourriture pour animaux, Seagull Pet Snacks. La base de données contient une section d'en-tête simple <HEADER> avec un corps de données contenu dans <DETAILS>.
<?xml version="1.0"?>
<LABEL>
<HEADER>
<BRAND>Seagull Pet Snacks</BRAND>
<PACKAGE>Bag</PACKAGE>
<LOCATION>Seattle</LOCATION>
<DETAILS>
<NAME>Kitty Kibble</NAME>
<TAGLINE>Delicious snacks for kitty</TAGLINE>
<FLAVOR>Salmon</FLAVOR>
</DETAILS>
</HEADER>
</LABEL>
Pour créer une base de données XML
- Ouvrez un éditeur de texte comme le Bloc-notes.
- Collez le texte ci-dessus dans votre éditeur.
- Allez dans Fichier > Enregistrer sous et changez le type d'enregistrement en Tous les fichiers.
- Donnez-lui un nom, par exemple Database.xml, puis cliquez sur Enregistrer.
Créer le fichier d'étiquette
- Ouvrez BarTender Designer et créez un nouveau document.
- Une fois l'assistant de nouveau document terminé, allez dans Fichier > Configuration de la connexion à la base de données.
- Sélectionnez Créer une nouvelle connexion à une base de données puis cliquez sur Suivant.
- Sélectionnez Fichier XML dans la liste puis cliquez sur Suivant.
- Utilisez le bouton Parcourir pour localiser le fichier database.xml. Sélectionnez-le puis cliquez sur Suivant.
- Pour ce tutoriel, sélectionnez la première option Détecter automatiquement le schéma à partir du fichier XML puis cliquez sur Suivant.
- L'écran suivant vous permet d'indiquer à BarTender où se trouvent réellement les données dans votre fichier XML.
Dans notre base de données ci-dessus, nous avons un en-tête nommé <HEADER> et une section qui détaille chaque enregistrement ou étiquette marquée comme <DETAILS>. Comme nous voulons seulement utiliser les informations de la section DETAILS comme base de données, sélectionnez-la dans la liste du volet supérieur comme illustré dans la capture d'écran ci-dessous :
Remarquez que l'aperçu du fichier change selon la balise sélectionnée. Le volet inférieur vous montre à quoi ressemblent vos données sous forme de tableau. Si l'aperçu apparaît sous forme de balises, cliquez sur l'onglet Champs à droite pour passer à l'affichage en tableau. - Avec la balise DETAILS sélectionnée dans le volet supérieur, cliquez sur Suivant.
- L'écran suivant vous permet de décocher des champs si vous souhaitez les ignorer. Pour cet exemple, nous laissons les 3 champs cochés. Cliquez sur Terminer dans l'assistant puis sur OK dans la boîte de dialogue.
- Maintenant que la base de données est connectée, cliquez sur l'onglet Sources de données dans votre boîte à outils si ce n'est pas déjà fait.
- Cliquez et faites glisser les trois champs sur votre étiquette.
Astuce : si le TAGLINE est trop large pour votre étiquette, vous pouvez activer le retour à la ligne dans la boîte de propriétés du texte, section retour à la ligne. - Enregistrez votre étiquette. Elle est maintenant prête à être utilisée !
Créer l'intégration
- Ouvrez Integration Builder.
- Depuis l'écran de démarrage, sélectionnez Créer une nouvelle intégration.
- Sélectionnez Fichier dans la boîte de dialogue puis cliquez sur OK.
- Sous Détection de fichier, choisissez l'emplacement de votre dossier de surveillance. C'est ici que l'intégration récupérera les fichiers.
Remarque : Il est recommandé de choisir un dossier à un emplacement courant comme le disque C. Les dossiers dans Mes documents ou sur le bureau peuvent nécessiter des autorisations spéciales pour y accéder. - Modifiez le modèle de fichier en *.xml, car nous allons rechercher des fichiers xml.
- Cliquez sur l'action Imprimer le document.
- Dans l'onglet Document, utilisez le bouton Parcourir pour naviguer jusqu'au document que vous avez créé à l'étape précédente. Comme pour le dossier de surveillance, il est recommandé que ce document soit situé dans un dossier centralisé et non dans Mes documents.
- Configurez l'option Surcharge de base de données.
BarTender 2019 : Dans l'onglet Options d'impression, sous Surcharges de base de données, cochez la case à côté de Utiliser la source de données et laissez l'option du menu déroulant sur Données d'entrée de l'intégration.
BarTender 2021 : Dans l'onglet Options d'impression, sous Surcharges de base de données, cliquez sur le bouton bleu plus pour ajouter une option de surcharge de base de données. Définissez la Source de données sur Variable et le champ Variable sur "%EventData%".
- Enregistrez votre fichier.
Tester et déployer l'intégration
Avant de déployer l'intégration, nous allons la tester et créer quelques fichiers déclencheurs d'exemple. Les fichiers déclencheurs doivent avoir la même structure que la base de données liée au fichier d'étiquette. Voici des données d'exemple pour les tests. Ces données sont différentes de celles de la base de données de l'étiquette mais la structure reste la même :
<?xml version="1.0"?>
<LABEL>
<HEADER>
<BRAND>Seagull Pet Snacks</BRAND>
<PACKAGE>Box</PACKAGE>
<LOCATION>Seattle</LOCATION>
<DETAILS>
<NAME>Dog Crunchies</NAME>
<TAGLINE>Crunchy snacks for your best friend!</TAGLINE>
<FLAVOR>Duck</FLAVOR>
</DETAILS>
</HEADER>
</LABEL>
- Créez un fichier déclencheur d'exemple en utilisant les données ci-dessus. Assurez-vous que l'extension du fichier est .XML, car c'est ce que l'intégration attend.
- Avec l'intégration ouverte, cliquez sur l'onglet Test.
- Cliquez sur le bouton vert Démarrer dans le ruban supérieur.
- Déposez le fichier dans le dossier de surveillance que vous avez défini à l'étape précédente.
- Des messages d'intégration vont commencer à apparaître, confirmant que l'intégration a bien détecté le fichier.
- Une fois que vous avez une impression réussie, il est temps de déployer.
- Cliquez sur l'onglet Déployer puis sur le bouton vert Déployer.
- Si vous n'avez pas enregistré votre fichier, il vous sera demandé de le faire.
- Cliquez sur le menu déroulant et sélectionnez Cet ordinateur dans la liste. Cliquez sur Suivant.
- Sélectionnez Déployer maintenant puis cliquez sur Terminer.
- Votre intégration est maintenant déployée.
Ressources supplémentaires
Imprimer un document à l'aide d'un script de commande d'impression (Vidéo - 9:40)
Créer une intégration de fichiers à l'aide d'un script de commande d'impression (27:58)